WordFly-Tessitura Integration v3 services upgrade

Upgrade to the WordFly-Tessitura Integration v3 services for the next generation of features and integration enhancements.


Topics covered in this article:

The v3 services benefits

How to upgrade to the v3 services

FAQs about the v3 services and upgrade

 

 

The v3 services benefits

 

At WordFly, we strive not only to be up to date with technology, but also to be forward thinkers. WordFly-Tessitura Integration v3 is our commitment to remain forward thinkers and innovate in the marketing space.

 

The v3 integration is a set of RESTful web services. The underlying technology used to host and access the services has changed, but the core functionality remains the same. All existing features have been preserved with the addition of a better import mechanism.

 

The v3 integration provides the following:

  • Improves overall integration security by running all server-to-server communication over HTTPS.
  • Eliminates the overhead and maintenance burden from the use of X509 Certificates on gateway servers.
  • Improves imports by using a polling service instead of keeping an open connection while streaming data from client servers to WordFly.
  • Facilitates the release of new features, revisions, and upgrades. For example, WordFly's new Pages feature will have the capability to send RSVP and Survey responses back to Tessitura.

 

 

How to upgrade to the v3 services

 

The v3 services installation package is available in your Account > Tessitura section. You will see your current services link in this section. Below the service endpoint section, click the link Check for WordFly-Tessitura Services Updates. This will update to show what version of the services your organization's WordFly-Tessitura Integration is currently running.

 

A quick note about hosting. If you are managing your own Tessitura server then your organization will continue following the instructions in this guide to upgrade the v3 services. If you are hosting with RAMP, please open a TASK ticket with RAMP to complete the v3 services upgrade.

 

In WordFly, go to Account > Tessitura, click Check for WordFly-Tessitura Services Updates,

 

 

The blue dropdown at the top of the application will provide the necessary installation files or confirm your services are up to date.

 

How to proceed after checking services version:

 

...If the service check returns v2.0x

  • Download the v3 services package from the in-app dropdown notifier.
  • Follow the pdf instructions included in the package.
  • Email support with the requested information when you're finished with the upgrade.

 

...If the service check returns v3.0x

  • Check the in-app dropdown notifier for next steps.
  • You may need to upgrade your services to the most up-to-date services version.
  • If you need to upgrade, download the latest services package from the dropdown notifier.
  • Follow the provided instructions in the package and complete the upgrade.
  • In WordFly, go to Account > Tessitura. Test the endpoint to confirm it is passing. Then click the link Check for WordFly-Tessitura Services Updates to confirm you are on the latest version.

 

The most recent v3 services package is: 3.0.1.121

 

 

 

FAQs about the v3 services and upgrade

 

Are the v3 services required for v14 Tessitura?

There are some v14 Tessitura server configurations that cause the v2 services to stop working. The v3 services are required in these cases.

Are the v3 services compatible with v12.5 Tessitura and earlier versions?

Yes! The v3 services are compatible with any version of Tessitura. It is highly recommended to upgrade to the new services before the v14 Tessitura upgrade.

Will the v3 services make imports faster?

No. There is nothing in here to speed the import process up. The new services do make the import process more reliable.

When will the new v3 integration services be available?

The new v3 services are available to all Tessitura integrated organizations right now.

Will I need to remove my old v2 integration?

No. The v3 integration is a standalone product which has no dependencies on the old integration. You will be able to keep your old integration files until it is officially retired in 2019.

Here are your options:

  • You can delete/remove the v2 services upon installing v3 services. This is the most drastic approach and doesn't allow for a fall-back.
  • You can leave the v2 services in place during the v3 upgrade and then remove the services once v3 is confirmed.
  • The most cautious approach is to leave v2 services in place and stop the services once the switch to v3 services is complete. At a later time the v2 services can be removed.


Is the old v2 integration eventually going to go away?

Yes! The v2 integration services will no longer be available after December 2018.

We host with RAMP, how do we do the upgrade?

RAMP will do the v3 services upgrade if you are hosting with them. Open a TASK ticket with RAMP and let them know you are ready for the v3 services.

 

 

 

Have more questions? Submit a request
Powered by Zendesk